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USER MANUAL

1. Introduction

To all residents of the European Union
Important environmental information about this product

This symbol on the device or the package indicates that disposal of the device after its lifecycle could
harm the environment. Do not dispose of the unit (or batteries) as unsorted municipal waste; it should
be taken to a specialized company for recycling. This device should be returned to your distributor or to
a local recycling service. Respect the local environmental rules.

I 1f in doubt, contact your local waste disposal authorities.

Thank you for choosing Velleman®! Please read the manual thoroughly before bringing this device into service.
If the device was damaged in transit, do not install or use it and contact your dealer.

2. Safety Instructions

This device can be used by children aged from 8 years and above, and persons with
reduced physical, sensory or mental capabilities or lack of experience and knowledge if
they have been given supervision or instruction concerning the use of the device in a
safe way and understand the hazards involved. Children shall not play with the device.
Cleaning and user maintenance shall not be made by children without supervision.

Indoor use only.
Keep away from rain, moisture, splashing and dripping liquids.

3. General Guidelines

Refer to the Velleman® Service and Quality Warranty on the last pages of this manual.
Familiarise yourself with the functions of the device before actually using it.

All modifications of the device are forbidden for safety reasons. Damage caused by user
modifications to the device is not covered by the warranty.

Only use the device for its intended purpose. Using the device in an unauthorised way
will void the warranty.

Damage caused by disregard of certain guidelines in this manual is not covered by the
warranty and the dealer will not accept responsibility for any ensuing defects or
problems.

Nor Velleman nv nor its dealers can be held responsible for any damage (extraordinary,
incidental or indirect) — of any nature (financial, physical...) arising from the possession,
use or failure of this product.

Due to constant product improvements, the actual product appearance might differ from
the shown images.

Product images are for illustrative purposes only.

Do not switch the device on immediately after it has been exposed to changes in
temperature. Protect the device against damage by leaving it switched off until it has
reached room temperature.

Keep this manual for future reference.
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4. What is Arduino®

Arduino® is an open-source prototyping platform based in easy-to-use hardware and software. Arduino® boards
are able to read inputs - light-on sensor, a finger on a button or a Twitter message — and turn it into an output
- activating of a motor, turning on an LED, publishing something online. You can tell your board what to do by
sending a set of instructions to the microcontroller on the board. To do so, you use the Arduino programming
language (based on Wiring) and the Arduino® software IDE (based on Processing).

Surf to www.arduino.cc and www.arduino.org for more information.

5. Overview

VMA100

The VMA100 (Arduino® Uno compatible) is a microcontroller board based on the ATmega328. It has 14 digital
input/output pins (of which 6 can be used as PWM outputs), 6 analogue inputs, a 16 MHz ceramic resonator,
a USB connection, a power jack, an ICSP header and a reset button. It contains everything needed to
support the microcontroller. Connect it to a computer with a USB cable or power it with an AC-to-DC adapter
or battery to get started.

1  USB interface 6 16 MHz clock
2  reset button 7 | Atmel mega328p (DIL)
3  digital I/O 8 7-12 VDC power input
4  Atmel megal6U2 9  power and ground pins
5 ICSP 10 analogue input pins
(aa] ol g'eYelo] ] g ] 1=T PP ATmega328
(o]0 1< =Yg Yo BAV/o] | = o [ OO 5VvDC
input voltage (reCoMmMENAEd) ...cviiiiiiii e e 7-12 VDC
INPUE VOItage (JIMIES) .ouue e 6-20 VDC
digital I/O PiNS cueeiiiii e 14 (of which 6 provide PWM output)
=1 at=] (T [U =T oYU ) o o] g PP 6
(DT @R oW [ = o 0T =T 7 I o o PP 40 mA
(DT O oW g = o) o oG T TV o 11 I P 50 mA
flash memory ... 32 kB (ATmega328) of which 0.5 kB used by bootloader
SR A e 2 kB (ATmega328)
EEPROM ..ttt 1 kB (ATmega328)
[ Lo Tl 1= o 1= =T [ PP 16 MHz
dimensions
LGN e 68.6 mm
WA L 53.4 mm
WBIGNT L e 25¢g
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VMA101

The VMA101 (Arduino® compatible) Mega 2560 is a microcontroller board based on the ATmega2560. It has
54 digital input/output pins (of which 15 can be used as PWM outputs), 16 analogue inputs, 4 UARTs
(hardware serial ports), a 16 MHz crystal oscillator, a USB connection, a power jack, an ICSP header, and a
reset button. It contains everything needed to support the microcontroller. Connect it to a computer with a
USB cable or power it with an AC-to-DC adapter or battery to get started. The Mega is compatible with most
shields designed for the Arduino® Duemilanove or Diecimila.

1 USB interface 7  Atmel mega2560
2  ICSP for 16U2 8 reset button
3 digital I/O 9 digital I/O
4 Atmel megal6U2 10 7-12 VDC power input
5  ICSP for mega2560 11  power and ground pins
6 16 MHz clock 12 | analogue input pins
[ e YoloT /o] | 1= PP ATmega2560
OPEratiNg VO G . .o i e e 5 VvDC
input voltage (reCoMmMENAEA) ...ceiuiiiiiii e e 7-12 VDC
INPUE VOIEAGE (JIMIES) ettt e e e e enes 6-20 VDC
digital I/O PiNS cuviriieiii e 54 (of which 15 provide PWM output)
=1 at=1 oo [N T=INT a] o U1 o] o = PR 16
(D @Rl U T o= ol o 1= ol 17 I o 1 o I N 40 mA
(D@ o{U T o= o ol (o] alC T T VA oY o S 50 mA
flash MEMOIY ..o e 256 kB of which 8 kB used by bootloader
1] 2 PPN 8 kB
] 2 ] PP 4 kB
ClOCK SPEEA .. e 16 MHz
dimensions
=T o T ) o o PP 112 mm
17 Lol o PP 55 mm
1T = T | o PN 62 g
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VMA102

The VMA102 (Arduino® compatible Nano 3.0) is a small, complete, and breadboard-friendly board based on
the ATmega328 (Arduino Nano 3.x) orATmegal68 (Arduino® Nano 2.x). It has more or less the same
functionality of the Arduino® Duemilanove, but in a different package. It lacks only a DC power jack, and
works with a mini-B USB cable instead of a standard one.

1 mini USB interface 5 reset button
2  digital I/O 6 ICSP
3  serial communication pins 7  analogue input pins
4  Atmel mega328p
MICrOCONEIOIEE vt e e Atmel ATmegal68 or ATmega328
fo] 01 =Y Yo BAV/o] | = o [PPSO 5VvDC
input voltage (recomMmMENAEd) ...viviiiiiieiii et e e 7-12 VDC
INPUE VOIEAGE (JIMIES) et e e e e e aenes 6-20 VDC
digital I/O PiNS cuviiiiiiii i 14 (of which 6 provide PWM output)
=1 at=1 (oo [T o UL o] o PP 8
(D@l U T o= o ol o 1= ol 17 I o 1 o IS 40 mA
flash MemoOry ...ovii 16 kB (ATmegal68) or 32 kB (ATmega328)
SRAM e 1 kB (ATmegal68) or 2 kB (ATmega328)
EEPROM . ...t e 512 bytes (ATmegal68) or 1 kB (ATmega328)
ClOCK SPEEA .. e 16 MHz
dimensions
=] o T ) o o P 45 mm
17 Lol o PP 18 mm
LT T | 5¢
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VMA103

The VMA103 (Arduino® compatible Leonardo) is a microcontroller board based on the ATmega32u4. It has 20
digital input/output pins (of which 7 can be used as PWM outputs and 12 as analogue inputs), a 16 MHz
crystal oscillator, a micro USB connection, a power jack, an ICSP header, and a reset button. It contains
everything needed to support the microcontroller. Connect it to a computer with a USB cable or power it with
an AC-to-DC adapter or battery to get started.
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1 USB interface 5 ICSP
2 reset button 6 7-12 VDC power input
3 digital I/O 7 power and ground pins
4  Atmel mega32U4 8 analogue input pins
(aa]Tolg'eYelolq g ] =T PP ATmega32u4
(o]0 1< =Yg Yo BAV/o] | = o [ OO 5VvDC
input voltage (reCcomMmMENAEd) ...viviiiriiiii it e 7-12 VDC
INPUE VOIEAGE (JIMIES) eviiiii it e e e e e e enes 6-20 VDC
(o [ Ta 3= Y I @ I o 11 I PR 20
=1 at=1 (e [U =TT o] UL il o] o = P 12
(DT @R oW [ = o 0T =T 7 I o o PP 40 mA
(DT OR oW [ = o) o o o T TV o 11 PP 50 mA
flash memory ... 32 kB (ATmega32u4) of which 4 kB used by bootloader
SR A e 2.5 kB (ATmega32u4)
[ 0 ] PP 1 kB (ATmega32u4)
ClOCK SPEEA .. e 16 MHz
dimensions
=T s ] o PP 68.6 mm
1777 e TR PRPPRP 53.3 mm
11T T | 20g
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6. How to Use
In the example below, we use the VMA100 to make an LED blink.

LR I B T I T T B IR R T R T O D R I I B B R IR R R A
L R R B I I B B R
LR I R I R O R R I O B R I
L I I I I R I LR I R T I I R T IR R I
R I R I L I I T I T B B I
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Connection.

First, download the latest Arduino® Integrated Development Environment (IDE) from the Arduino® page.

https://www.arduino.cc/en/Main/Software

Install the software and use a USB cable to connect your VMA board to your computer.

a. LED13 will blink.
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Next, launch the Arduino® application and click File > Examples > 01. Basics > Blink.

Blink | Arduino 1.0

Blink

Blink
Turns on an LED on for one second, then off for one second, repeatedly.

This example code is in the public domain.
%/

void setup() {
Y/ initialize the digital pin as an output.
Z¢ Pin 13 has an LED connected onh most Arduino boards:
pinMode(13, OUTPUT);

1

void loop() {
digitalWrite(13, HIGH); // set the LED on
de Loy {1008) ;
digitalWrite(13, LOW);
de Loy (1688 );

/it for a second
et the LED off
fwait for a second

Arduino Uno on /dev/tty.usbmodemfd131

You will need to select the used board. To do so, click Tools > Board.

Sketch Help

Auto Format ®BT
Archive Sketch

Fix Encoding & Reload
Serial Monitor M

 Arduino Uno

Serial Port Arduino Duemilanove or Nano w/ ATmega328
Arduino Diecimila, Duemilanove, or Nano w/ ATmegal68
Burn Bootloader > " Arduino Mega 2560
Arduino Mega (ATmegal280)
Arduino Mini
Arduino Fio E
Arduino BT w/ ATmega328
Arduino BT w/ ATmegal68
LilyPad Arduino w/ ATmega328
LilyPad Arduino w/ ATmegal68 gd
Arduino Pro or Pro Mini (5V, 16 MHz) w/ ATmega328 g
Arduino Pro or Pro Mini (5V, 16 MHz) w/ ATmegal68 [P
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmega328
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmegal68
Arduino NG or older w/ ATmegal68 ‘
Arduino NG or older w/ ATmega8 P

e
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Select the serial device of the Arduino board. To do so, click Tools > Serial Port.

Help

Auto Format ¥T Arduino 0020

Archive Sketch

Fix Encoding & Reload

Serial Monitor {+8M E

Board »

Serial Port 2 [dev/tty.usbmodem262471
/dev/cu.usbmodem262471
/dev/tty.Bluetooth-Modem
/dev/cu.Bluetooth-Modem
/dev/tty.FireFly-7256-SPP
/dev/cu.FireFly-7256-SPP
/dev/tty.tiPhone-WirelessiAP-1
/dev/cu.tiPhone-WirelessiAP-1
/dev/tty.Bluetooth-PDA-Sync
/dev/cu.Bluetooth-PDA-Sync

Burn Bootloader [ 2

The LED should now be blinking.

Use this device with original accessories only. Velleman nv cannot be held responsible in the event
of damage or injury resulting from (incorrect) use of this device. For more info concerning this
product and the latest version of this manual, please visit our website www.velleman.eu. The
information in this manual is subject to change without prior notice.

© COPYRIGHT NOTICE

The copyright to this manual is owned by Velleman nv. All worldwide rights reserved. No part of this
manual may be copied, reproduced, translated or reduced to any electronic medium or otherwise without the
prior written consent of the copyright holder.
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Velleman® Service and Quality Warranty

Since its foundation in 1972, Velleman® acquired extensive experience in the electronics world and currently
distributes its products in over 85 countries.

All our products fulfil strict quality requirements and legal stipulations in the EU. In order to ensure the quality,
our products regularly go through an extra quality check, both by an internal quality department and by
specialized external organisations. If, all precautionary measures notwithstanding, problems should occur,
please make appeal to our warranty (see guarantee conditions).

General Warranty Conditions Concerning Consumer Products
(for EU):

¢ All consumer products are subject to a 24-month warranty on production flaws and defective material as from
the original date of purchase.

¢ Velleman® can decide to replace an article with an equivalent article, or to refund the retail value totally or
partially when the complaint is valid and a free repair or replacement of the article is impossible, or if the
expenses are out of proportion.

You will be delivered a replacing article or a refund at the value of 100% of the purchase price in case of a flaw
occurred in the first year after the date of purchase and delivery, or a replacing article at 50% of the purchase
price or a refund at the value of 50% of the retail value in case of a flaw occurred in the second year after the
date of purchase and delivery.

e Not covered by warranty:

- all direct or indirect damage caused after delivery to the article (e.g. by oxidation, shocks, falls, dust, dirt,
humidity...), and by the article, as well as its contents (e.g. data loss), compensation for loss of profits;

- consumable goods, parts or accessories that are subject to an aging process during normal use, such as
batteries (rechargeable, non-rechargeable, built-in or replaceable), lamps, rubber parts, drive belts...
(unlimited list);

- flaws resulting from fire, water damage, lightning, accident, natural disaster, etc....;

- flaws caused deliberately, negligently or resulting from improper handling, negligent maintenance, abusive
use or use contrary to the manufacturer’s instructions;

- damage caused by a commercial, professional or collective use of the article (the warranty validity will be
reduced to six (6) months when the article is used professionally);

- damage resulting from an inappropriate packing and shipping of the article;

- all damage caused by modification, repair or alteration performed by a third party without written permission
by Velleman®.

e Articles to be repaired must be delivered to your Velleman® dealer, solidly packed (preferably in the original
packaging), and be completed with the original receipt of purchase and a clear flaw description.

¢ Hint: In order to save on cost and time, please reread the manual and check if the flaw is caused by obvious
causes prior to presenting the article for repair. Note that returning a non-defective article can also involve
handling costs.

e Repairs occurring after warranty expiration are subject to shipping costs.
e The above conditions are without prejudice to all commercial warranties.

The above enumeration is subject to modification according to the article (see article’s manual).

Made in PRC

Imported by Velleman nv

Legen Heirweg 33, 9890 Gavere, Belgium
www.velleman.eu
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